Jump to content
turkasoft

Table 'dbadı.forums' doesn't exist Hatası!

Önerilen İletiler

turkasoft    0

Herkese merhabalar, 4.1.19.4 sürümünden 4.2.2 sürümüne geçiş yapmak için dosyaları sunucuya gönderdim ve güncelleme işlemine başladım fakat  resimde ki gibi bir hata veriyor.

Dosyayı incelediğimde;

{
    "1": {
        "method": "renameTable",
        "params": [
            "forums",
            "forums_forums"
        ]
    },
    "2": {
        "method": "renameTable",
        "params": [
            "topics",
            "forums_topics"
        ]
    },
    "3": {
        "method": "renameTable",
        "params": [
            "posts",
            "forums_posts"
        ]

Tablo isimlerinin değiştiriliyor olduğunu gördüm. fakat nedense bu işemiyor heraldeki "Table 'DATABASE-ADI.forums' doesn't exist " gibi bir hata veriyor sistem.

Her tarafı aradım taradım fakat her hangi bir şey bulamadım. Yardımcı olabilirseniz sevinirim.

update.png

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
Oscar    1.554

Eski conf_global.php dosyasını ellemediyseniz böyle bir hata vermiş olmamalı.  forum ana forum tablosudur. Muhtemelen sorun tablodan değilde database prefix ayarındandır.  Veritabanında bir önek varsa ibf_forums gibi mesela onu kontrol edin. 

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
turkasoft    0
Oscar, 5 dakika önce yazdı:

Eski conf_global.php dosyasını ellemediyseniz böyle bir hata vermiş olmamalı.  forum ana forum tablosudur. Muhtemelen sorun tablodan değilde database prefix ayarındandır.  Veritabanında bir önek varsa ibf_forums gibi mesela onu kontrol edin. 

conf_global.php dosyasını ellemedim ve tablolarda prefix yok. Daha farklı ne yapılabilir çözebilirsek çok sevinirim.

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
Oscar    1.554

Hata mesajını kapatmasaydınız daha kolay anlaşılırdı.  

phpmyadmin ile bakın bakalım forums.forums tablosu var mı? Varsa ve bu hatayı alıyorsanız IPS'ye ticket atabilirsiniz.  Yerinde müdahale edilemeden çözülmeyebilir. 

 

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
turkasoft    0

site adını kapattım  hata mesajı duruyor. Ticket ile uğraşmak istemiyorum açıkçası, aklıma şöyle bir şey geldi çalışır mı emin değilim. sıfırdan 4.2.2 kurayım daha sonra veritabanını temizleyip eski yedeği olduğu gibi içe aktarayım diyorum olur mu sizce ?

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
Oscar    1.554

Farklı hata mesajalrı verimişsiniz onun için kapatmasaydınız keşke demek istedim. 

 

Başlıkta bunu demişsiniz = Table 'dbadı.forums' doesn't exist

Konu içinde bunu yazmışsınız = Table 'DATABASE-ADI.forums' doesn't exist

 

Hangisi doğru bilmiyorum ama ya eski forumunuz 4.1.19.x değil veya öyle siz forum tablosunu bir şekilde silmişsiniz. Veya tablo var ama güncelleme onu bulamıyor. 

 

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
turkasoft    0

Table 'burada veritabanının adı yazıyor  .forums' doesn't exist  sitenin adı geçtiği için kapattım farklı değil o yüzden. 

Eski forumun sürümü 4.1.19.4 güncellemeyi henüz yapamadığımdan dolayı yönetim panelinde hala sürümü görebiliyorum. Bu sorundan önce veritabanıyla herhangi bir ilişkim olmadı şimdi sorduğum yöntemi deneyeceğim gözden çıkarttım resmen. Başarılı olursam buradan bildiririm.

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
Oscar    1.554

4.1 sürümünde veritabanıadı_forums şeklinde bir yapı yok.  Forum tablosu forums_forums şeklindedir.   

 

Sizin sitenizin adı forums.com ise sitenin adı geçiyor sanıp kapatmış olabilirsiniz.  !!!

IPB4 forum veritabanı tablolarında hiç bir yerde sitenin adı geçmez. 

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş
turkasoft    0

Beni yanlış anladınız sanırım.Ben veritabanına isim verirken sitenin adını yazmıştım o yüzden sitenin adı geçiyor. Tablolarda geçmiyor yani.
Sizinde söylediğiniz gibi forums diye bir yapı yok forums_forums / forums_topics gibi yapılar var ama içeriğinin bir kısmını verdiğim dosyanın içinde gördüğünüz gibi tablo isimleri değiştiriliyor.

 

   "1": {
        "method": "renameTable",
        "params": [
            "forums",
            "forums_forums"
        ]

forums_forums ---forums olarak değiştiriliyor haliyle update yaparkende dbadı.forums_forums değilde dbadı.forums olarak işlem yapıyor. Bir kaç şey deneyeceğim forumu gözden  çıkarttım dediğim gibi hırs yaptım bu sorunu çözecem :)

İletiyi paylaş


İletiye bağlantı
Sitelerde Paylaş

Hesap oluşturun veya yorum yazmak için oturum açın

Yorum yapmak için üye olmanız gerekiyor

Hesap oluştur

Hesap oluşturmak ve bize katılmak çok kolay.

Hesap Oluştur

Giriş yap

Zaten bir hesabınız var mı? Buradan giriş yapın.

Giriş Yap

  • Konuyu Görüntüleyenler   0 kullanıcı

    Sayfayı görüntüleyen kayıtlı kullanıcı bulunmuyor.

×

Önemli Bilgilendirme

Forum kurallarımızı okudunuz mu? Forum Kuralları.